Внимание! Обнаружена самая серьезная веб-уязвимость в истории Интернета

Вчера стало известно, что одна из популярнейших криптографических библиотек OpenSSL содержит критическую уязвимость. Ошибка, получившая название HeartBleed, позволяет хакерам получить доступ к любым коммуникациям, защищенным уязвимой версией OpenSSL (1.0.1, 1.0.2-beta, включая 1.0.1f и 1.0.2-beta1). Это 2/3 веб-сайтов Интернета! Уязвимость существует с 2012 года!

heartbleed

Уязвимость связана с отсутствием необходимой проверки границ в одной из процедур расширения Heartbeat (RFC6520) для протокола TLS/DTLS. Из-за ошибки программистов The OpenSSL Project, кто угодно получает прямой доступ к оперативной памяти компьютеров, чьи коммуникации «защищены» уязвимой версией OpenSSL. В том числе, злоумышленник получает доступ к секретным ключам, именам и паролям пользователей и всему контенту, который должен передаваться в зашифрованном виде. При этом не остается никаких следов проникновения в систему.
Читать далее Внимание! Обнаружена самая серьезная веб-уязвимость в истории Интернета